Knowledge Base

'[Pervasive] [ODBC Client Interface] [LNA] [Pervasive] [ODBC Engine Interface] Unable to open table: tablename'

Solution ID: 00015187

Problem Description

When attempting to drop a table from the Pervasive Control Center, the following error message is received: ''[Pervasive] [ODBC Client Interface] [LNA] [Pervasive] [ODBC Engine Interface] Unable to open table: tablename''

''[Pervasive] [ODBC Client Interface] [LNA] [Pervasive] [ODBC Engine Interface] Unable to open table: tablename''

Problem Environment

Pervasive.SQL 2000

Cause of the Problem

This results from trying to drop a table definition from the Pervasive Control Center after deleting or renaming the actual physical file (the data file) associated with the table definition.

Solution Notes

The table is still seen in the Pervasive Control Center because it is still defined to the Data Dictionary Files (DDFs). You may use the
''Drop Table'' wizard to delete the table definition so that it will not display in the Pervasive Control Center. To avoid the error message, simply
remove the checkmark for ''Delete Data File''.

Published: June 2002_

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